概要
Device Automation(DA)でfinder(ファインダー)の設定をしようとすると、
下記エラーメッセージが表示され、設定出来ない場合があります。
エラーメッセージ
英語:Cannot create a unique finder for the selected element.
日本語:選択した要素に対して一意なファインダーを作成できません。
原因
下図のようにオートメーションデバイスビューの下段にあるツリービューの一番上にROOT要素名がない([jexplore.exe]などのプロセス名が表示されていない)場合、選択した要素からファインダーを設定することができません。
ROOT要素が認識できない原因としては以下が考えられます。
・実行権限の問題で、操作対象アプリケーションの要素が取得できていない
・操作対象のアプリケーションが、UIオートメーションに対応していない
BizRobo!はアプリケーションの認識に、UIオートメーションフレームワークを使用しております。
操作対象のアプリケーションが、UIオートメーションに対応していない場合、
ROOT要素名が認識できません。
対処方法
まずは、実行権限による問題を疑い、以下のナレッジを参考にDASを管理者権限で起動し、
要素が認識されるようになるかご確認下さい。
<参考記事>
「管理者として実行」により起動されたアプリケーションをDeviceAutomationで操作する方法
DASを管理者権限で起動しても要素が認識されない場合、以降の手順をご確認下さい。
10.3以降の場合
UIオートメーション非対応のアプリケーションをBizRobo!で操作することはできかねますので、該当アプリケーションをUIオートメーション対応のアプリケーションへ改修していただく必要があります。
10.2以前の場合
finder を手動入力することが可能です。
※10.3では使用出来ませんので、ご注意ください。
※finder の Image フィールドへは手動で画像を入力できないので、画像処理を利用できません。
手動入力:
区分 | 確認Ver |
仕様 | 10.3.0.7 |