発生バージョン・改修ID・修正バージョン
発生Ver | 改修ID | 修正Ver |
Desktop Automation Service 10.7 |
2068648 |
事象
Desktop Automation Service(以降DAS)を利用するロボットの実行が終了しているにもかかわらず、Management Console(以降MC)上の管理 > デバイスタブに表示されているステータスが"使用中"のままになっており、後続のロボットで該当のDASが利用できなくなる場合があります。
〇MC > 管理 > デバイスタブ
原因
DAS側のログの出力関連の処理で遅延が発生したことにより、ロボット実行完了時の処理が想定通りの順番で行われず、本来であれば、DASからMCに利用可能になったことを通知するところ、誤った情報(使用中)を送信し続けてしまうため
発生条件
以下の条件が組み合わさることで事象が発生する可能性があります。
- DASのログレベルの変更によるログの出力量の増加
- アンチウィルスソフトの影響等、外的要因による処理の遅延
- 端末のリソース不足(仮想マシンの場合、ホスト側の負荷等)による端末全体の処理速度の低下
対処方法
事象が発生した場合には、DASを再起動することでロボットが実行可能な状態に戻すことが可能です。また、併せて事象の回避にむけて以下の点を確認してください。
①DASのログレベルの変更
調査目的でテクニカルサポートからDASのログレベルの変更を依頼されており、"ALL"等に変更している場合は、元のログレベル(デフォルトはWARN)に戻して事象が改善するか確認してください。
<参考記事>DASのログレベルを変更する方法
②ウィルス対策ソフトの設定
ウィルス対策ソフトの除外設定が未実施の場合は、設定を実施することで事象が改善するか確認してください。
<参考記事>ウィルス対策ソフト(セキュリティソフト/アンチウイルスソフト)導入時の対応
③端末のリソースの確保
前述の通り、端末の負荷の影響でも事象が発生する可能性があります。
①、②でも事象が改善しない場合にはリソースモニター等でDASが稼働する端末の負荷状況を確認してください。
確認の結果、もし、メモリやCPU等の負荷が懸念される場合には、不要なアプリケーションの停止やリソースに余裕のある別端末への変更、リソースの増強等をご検討ください。