【ver.11.X】BizRobo! Basic 対応ソフトウェア・互換性マトリックス

フォローする

attention_MyBizRobo.png

概要

各バージョンのBizRobo! Basic で対応しているOS、DB、その他ソフトウェアのマトリックス表です。

最新のマトリックス表はこちらからダウンロードください。

下記の画像はクライアント端末、本番運用時のServer OSやDB、Tomcatの対応バージョン表となります。
記載のないものはテストしていないものとなり、サポート対応の対象外になります。

例として、未対応のOS使用時に発生した事象に関するお問い合わせいただいた場合は、対応OSを対象とした調査をおこないます。
調査の結果より、対応OSのご使用をご案内させていただく場合がございます。

※Oracle 12cについては、 R1のみ対応。(R2はサポートしていません。※対応予定時期未定)

関連ナレッジサイト: Tomcatの最新バージョンには対応していないのでご注意ください(2020年2月現在)

 

補足

Lite/Lite+は、OSはWindows、DBはMySQLのみ対応

BizRobo! mini およびBizRobo! DX Cloudは、Design StudioとDesktop Automationのみ対象となります。
 ※BizRobo! DX Cloudについては、Management Consoleへアクセスするためのブラウザも対象

 

Version of BizRobo! ver.10.7 ver.11.1 ver.11.3 v11.4 補足
Design Studio (For Basic, mini, DX Cloud)
オペレーティングシステム         補足
Windows 7 Enterprise (32-bit)        
Windows 7 Enterprise (64-bit)        
Windows 7 Professional (32-bit)        
Windows 7 Professional (64-bit)        
Windows 7 Ultimate (32-bit)        
Windows 7 Ultimate (64-bit)        
Windows 10 Enterprise (64-bit)  
Windows 11 Enterprise (64-bit)        
CentOS     CentOS は ver 11.3.0 以降で非推奨になります
Red Hat Enterprise Linux 7.x     
Ubuntu 14.04 LTS        
Ubuntu 16.04 LTS    
Ubuntu 20.04 LTS        
           
Desktop Automation Service (For Basic, mini, DX Cloud)
オペレーティングシステム         補足
Windows 7 Pro, Enterprise or Ultimate (32-bit)         
Windows 7 Pro, Enterprise or Ultimate (64-bit)         
Windows 10 Pro or Enterprise (32-bit)       
Windows 10 Pro or Enterprise (64-bit)   
Windows 11 Pro or Enterprise (64-bit)        
Windows Server 2012        
Windows Server 2016    
Windows Server 2019  
Windows Server 2022        
           
Management Console (For Basic)
アプリケーションサーバ          補足
Apache Tomcat 8.5.78 以降       ・Oracle Java SE 1.8 ランタイム
・Oracle Java SE 11.0.2 LTS ランタイム
・OpenJDK 1.8 ランタイム
Apache Tomcat 8.5.78 64 bit 以降       ・Oracle Java SE 1.8 ランタイム
・Oracle Java SE 11.0.2 LTS ランタイム
・OpenJDK 1.8 ランタイム
Apache Tomcat 9.0.50 以降 (バージョン10.x を除く)     ・OpenJDK 11.x
IBM WebSphere 8.5 with Java 1.8       
IBM WebSphere 8.5 with Java 11          
データベース         補足
Oracle 11g R1         
Oracle 12c         
Oracle 18.4       Oracle 18.4は11.3.0 以降で非推奨になります
Oracle 19c    
Oracle 21c      
DB 2 9.7      DB2 の場合、「LANGUAGE RPGLE」で記述されたストアド プロシージャはサポート対象外です。代わりに「LANGUAGE SQL」を使用してください。
Microsoft SQL Server 2014        
Microsoft SQL Server 2016     Microsoft SQL Server 2016は11.3.0 以降で非推奨になります
Microsoft SQL Server 2017  
Microsoft SQL Server 2019    
MySQL 5.6        
MySQL 5.7  
MySQL 8.0 Ver.11.4では、MySQL8.0.32+jdbc8.0.22を推奨
Postgres 10.5      
Postgres 10.16      
Postgres 13.2      
ブラウザ         補足
Internet Explorer version 11;        
Chrome version 72 and later;       
Chrome version 96 and later;        
Chrome version 104 and later;        
Firefox version 65 and later;      
Firefox version 88 and later;          
Firefox version 91.3 and later;        
Firefox version 102 and later;        
RoboServer (For Basic)
オペレーティングシステム         補足
Windows 7 Enterprise (32-bit)        
Windows 7 Enterprise (64-bit)        
Windows 7 Professional (32-bit)        
Windows 7 Professional (64-bit)        
Windows 7 Ultimate (32-bit)        
Windows 7 Ultimate (64-bit)        
Windows 10 Enterprise (64-bit)  
Windows 11 Enterprise (64-bit)        
Windows Server 2016    
Windows Server 2019  
Windows Server 2022        
CentOS     CentOS は ver 11.3.0 以降で非推奨になります
Red Hat Enterprise Linux 7.x     
Ubuntu 14.04 LTS        
Ubuntu 16.04 LTS    
Ubuntu 20.04 LTS        
           
Kapplets (For Basic)
アプリケーションサーバ         補足
Apache Tomcat 8.5.78 64 bit 以降       ・Oracle Java SE 1.8 ランタイム
・Oracle Java SE 11.0.2 LTS ランタイム
・OpenJDK 1.8 ランタイム
Apache Tomcat 9.0.50 以降 (バージョン10.x を除く)     ・OpenJDK 11 以降で実行
データベース         補足
Oracle 18.4       Oracle 18.4は11.3.0 以降で非推奨になります
Oracle 19c    
Oracle 21c      
Microsoft SQL Server 2016        
Microsoft SQL Server 2017    
Microsoft SQL Server 2019    
MySQL 5.7     
MySQL 8.0   Ver.11.4では、MySQL8.0.32+jdbc8.0.22を推奨
Postgres 10.5        
Postgres 10.16      
Postgres 13.2